DJI have issues an update for the DJI GO App 3 ( the one for Phantom 3, Inspire 1, Osmo, M600 ) and removed support for the Mavic and Phantom 4 range. This means that from now on, users of these devices MUST use the DJI GO App 4. This should not be an issue for the majority but those stuck in time and liking the old app have very little options.

What’s New in Version 3.1.6
M600:
– Fixed bugs causing occasional screen blurs during Live View.
– Fixed bugs causing Z30 Peak Focus to remain on after shutdown.

General:
Cancelled support for Mavic Pro and Phantom 4.

(Visited 258 times, 2 visits today)